Resolved
We have applied a fix and are monitoring the system to confirm that service has fully recovered.
Monitoring
We have applied a fix and are monitoring the system to confirm that service has fully recovered.
Identified
We've identified the root cause and are applying a fix.
Investigating
We're seeing degraded performance for some requests on Biomni Lab. We are currently investigating and we will share more once we have more details.