The root cause, a WorkOS email delivery issue, is now resolved: https://status.workos.com/incidents/cdfqw1llf8mc
Resolved
The root cause, a WorkOS email delivery issue, is now resolved: https://status.workos.com/incidents/cdfqw1llf8mc
Identified
We're experiencing login code deliverability delays for Biomni Lab users whose email addresses are served by Microsoft 365 tenant domains (i.e. not consumer domains such as outlook.com, hotmail.com, live.com or msn.com).
We're monitoring the root cause, a WorkOS email delivery issue, and will provide updates as they're available: https://status.workos.com/incidents/cdfqw1llf8mc